Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 26, 2023 - 22:00 CEST
Scheduled
Urgent maintenance work as from 10 p.m.
From September 26, 2023, 10 p.m. until approximately September 26, 2023, 10:30 p.m., short-term urgent maintenance work for Customs Management will take place. During this time, message exchange with the customs authorities will not be possible.
Posted Sep 26, 2023 - 12:15 CEST
This scheduled maintenance affected: Customs Management (International Customs Integration).