Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 30, 2023 - 22:00 CET
Scheduled
From November 30. 2023, 10 p.m. until approximately 10:30 p.m., short-term urgent maintenance work for Customs Management will take place. During this time, message exchange with the customs authorities will not be possible.
Posted Nov 30, 2023 - 15:54 CET
This scheduled maintenance affected: Customs Management (International Customs Integration).