Interruption of Mail services caused by Microsoft issue

Incident Report for AEB Cloud

Update

We are seeing improvement in the issue affecting deferred emails, and impacted customers should begin receiving previously delayed messages.
Microsoft appears to be resolving the underlying issue on a per-tenant basis within Exchange Online. As a result, recovery timing may vary between customers and is outside of AEB’s direct control.
We are continuing to monitor the situation and are awaiting full confirmation from Microsoft that the issue has been completely resolved.
Posted Sep 04, 2026 - 16:27 CEST

Monitoring

We have identified an issue caused by Microsoft which is disrupting exchange online and therefore emails sent from AEB to customers, this is being investigated by Microsoft currently and this status page will be updated when we receive further information.
Posted Sep 04, 2026 - 14:53 CEST