Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 12, 2026 - 22:00 CEST
Scheduled
From 12/05/2026, 10pm until approximately 10:30pm, short-term urgent maintenance work for Export Filing will take place. During this time, the applications are not available.
Posted May 12, 2026 - 15:51 CEST
This scheduled maintenance affected: Customs Management (Export Filing: ATLAS (DE)).